XAMPP: SOAP-Erweiterung nicht geladen

So kannst du die Fehlermeldung SOAP-Erweiterung nicht geladen (konfigurieren Sie PHP mit --enable-soap) beheben, wenn du unter Contao den Erweiterungskatalog nutzen willst.

Zusammenfassung der nötigen Schritte

Schritt 1:
Im XAMPP Control Panel bei Apache unter Konfig auf den Menüpunkt PHP (php.ini) klicken.

Schritt 2:
MIt Hilfe der Suchfunktion nach dem Begriff soap suchen.

Schritt 3:
Das Semikolon vor dem Eintrag extension=soap entfernen.
(Achtung, das Video zeigt hier noch den Eintrag einer älteren XAMPP-Version)

Schritt 4:
Datei speichern und den Apache-Server von XAMPP neu starten.

Anschließend sollte sich die Erweiterungsverwaltung problemlos aufrufen lassen.

Tutorial getestet mit Contao:
  • 3.5
Hat dir dieser Artikel gefallen?

Willst du in Zukunft keinen Artikel verpassen?
Dann trage hier deine E-Mailadresse ein und klicke auf "Abonnieren". Du erhältst regelmäßig aktuelle Infos über Contao und die Contao-Academy.

Wir geben deine Daten niemals an Dritte weiter! Du kannst deine E-Mailadresse jederzeit mit nur 1 Klick wieder aus unserem System löschen. Datenschutzhinweis

Über den Autor
Christian Feneberg (Gründer Fenepedia)

Christian Feneberg ist der Gründer der Contao-Academy und nutzt seit 2010 Contao. Neben Contao begeistert er sich für Online-Marketing, Unternehmertum und Persönlichkeitsentwicklung.

Folge Christian jetzt auf Twitter, Facebook, Instagram und Xing.

2 Kommentare

Sascha Gerritzen |

Moin Moin Klasse Video eine Anmerkung habe ich den noch da zu

So folgendes habe ich da zu als Bemerkung

Im Video heist die Datei
extension=php_soap.dll

in XAMPP Control Panel v3.2.2

heist die Datei

extension=soap

grus aus Hamburg

Carlo Piper |

Hallo,

bei mir hat das nicht richtig funktioniert. Wie Herr Gerritzen bereits beschrieben hat, heißt die Datei nur extension=soap. Dort kann ich das Semikolon entfernen und schließlich erscheint auch der Erweiterungskatalog. Allerdings lädt sich in der Folge Contao tot. Es lädt alles dermaßen langsam, dass meist eine Fehlermeldung erscheint.

Füge ich das Semikolon wieder hinzu, funktioniert alles wieder. Gibt es da eine Lösung?

Christian Feneberg Antwort von Christian Feneberg

Hallo Carlo,

danke für den Hinweis. Ich habe das ganze noch mal geprüft.

Korrekt ist, dass inzwischen der Eintrag nur noch extension=soap lautet. Ich habe das gleich angepasst.

Allerdings funktioniert bei mir nach dem aktivieren der Zeile alles fehlerfrei.

Einen Kommentar schreiben

Was ist die Summe aus 2 und 3?