MAMP 6.6 Fehler: "Error handling the Composer Resolver Cloud. Please try again later"

Problem:

MAMP liefert leider eine zu alte OpenSSL-Version mit (siehe auch FAQ MAMP OpenSSL)

Workaround für MAMP:

Es muss das sogenannte "Certificate Authority Root Certificate" aktualisiert werden.

Führe folgende Schritte aus:

  1. Diese Datei herunterladen https://curl.haxx.se/ca/cacert.pem
  2. Datei nach /Applications/MAMP/Library/OpenSSL/certs/ kopieren
    (Original-Datei vorher sichern)
  3. php.ini der entsprechenden PHP Version anpassen
    (File > Open Template > PHP > Version)
  4. [openssl]
    openssl.cainfo=/Applications/MAMP/Library/OpenSSL/certs/cacert.pem
    openssl.cafile=/Applications/MAMP/Library/OpenSSL/certs/cacert.pem
  5. MAMP Pro neu starten

Hinweis für Konsole

Solltest du noch Probleme über die Kommandozeile haben, dann prüfe welche php.ini dort verwendet wird.

Befehl: which php

Beispielausgabe

php: aliased to /Applications/MAMP/bin/php/php7.4.21/bin/php -c "/Users/username/Library/Application Support/appsolute/MAMP PRO/templates/php7.4.21.ini.temp"

Danksagung

Danke an Corsin Simeon und Patrick Weiss
Quelle: https://github.com/contao/contao-manager/issues/661#issuecomment-937540264

Zuletzt aktualisiert am 18.10.2021 von Christian Feneberg.

Zurück